Diablo 3 stuck on updating blizzard update agent

I start the launcher and it doesn't show anything but the phrase "Updating Tools (0%)" at the bottom with no progress even after having it open all night and the Play button grayed out...Also when I tried to install Diablo 3 (real version) from I have it downloaded and installing it gets to a certain point halfway throughout the bar and stops with no further progress even after having it open an entire night as well...Not sure if that's true - but if my installer crashes again (ugh, from 72% complete to restarting at 0, sadface) I will try it and post here to update. For example there is no old connections in my internet settings to even remove. I am however looking for an alternative solution as the above doesnt work for me.

diablo 3 stuck on updating blizzard update agent-45

If that doesn't help, delete the folder Battle.net/Agent (probably in your Application Data or App data directories, use search if you can't find it). This is helping people with some updating issues, don't know if it will fix yours. You can also disable firewalls as this can cause network problems (remember to re-enable them again afterwards though).

If that doesn't help, delete the folder Battle.net/Agent (probably in your Application Data or App data directories, use search if you can't find it). This is helping people with some updating issues, don't know if it will fix yours.

If your launcher aint opening when you try to install the beta I made a lil guide for you guys how to solve the problem.

It has helped a lot of players so far and I hope it can be of help to someone here at MMO-champion aswell.

maybe it's something else for me because it still just won't work =( Hope it works for everyone else, maybe I'll find something that works for me! Are you sure something else like your firewall is not blocking the connection?

You could also try to do the same but start your windows in Safe Mode with Network and run the installer.

I have tried to shutdown my firewall, taken away the from task manager and deleted the file, but my installation is still stuck at 10% and have been so over an hour now.

When I stop the all that happens is that my installation goes back down to 0% and stay there until I quit it and have to reinstall it again, where I get the same problems as before... According to a few posts on the official forums, it's not necessary to delete the entire folder, just the 'agent' folder inside the folder. I am however looking for an alternative solution as the above doesnt work for me.

I have now installed, and uninstalled the 1st 10% about 50 times this morning, tried in safe mode with networking, tried disabling all my other connections, had a look for any stray dial ups and/or vpn's in IE - nothing there so I have no idea why this is doing what it is doing!

There is, however, one last thing that might work which I wanted to see if anyone else may have tried it - by going into the beta test install folder and running the the standard 'Wo W' executable seems to take me to the login screen - if I leave the client idling there, does it download the game files from there, or do I have to actually try and log into a server?

Hey guys , I installed Open beta Diablo 3 today and when i launch it it says initializing in start and then after sometime pops a message " An unexpected Error occurred while updating required files . so i tried closeing the launcher and opening in it again, now it just says : Updating blizzard launcher (0%) Anyone else have this problem?

Tags: , ,